3 New Notifications

New Badge Earned
Get 1K upvotes on your post
Life choices of my cat
Earned 210

Drag Images here or Browse from your computer.

Trending Posts
Sorted by Newest First
Gorelyi 02.06.22 10:03 pm

Running mods on pirate version 17.0 does not work. (Snowrunner)

Dear help with the launch of mods ... disconnecting from the Internet as on 16.1 does not help. Can eat what infa on treatment of a problem.
Sort by:
fghfb1 12.06.22

Same thing doesn't work for me

server23 12.06.22

on version 17.0 with the Internet turned off, all the mods went, but as soon as the Internet turned on, half of the workers became. ideally, I have 2 game folders 16.0 and 17.0 on the old one, all mods fly.

Orionchik 12.06.22

Mlyat, they clamp it so that people start buying the game ... everything is ok, I bought
it But there is no progress, but everything from the beginning goes through the manal this thing)))
People who found a solution?

Berik Makishev 12.06.22

It doesn’t start at all for me, what should I do? Black screen with a wheel, removed the folder in saves

Orionchik 12.06.22

Tell me more, my mods are blocked right away, I can’t load them, only standard cars

vermut61 12.06.22

I just wanted to post a link to the forum page, but for some reason this post was deleted there.
Therefore, I copy the text of the user under the nickname ProducerHenry95, translated by Google. Personally, after all the manipulations, the mods worked for me.
Here is the text:

Here's what I did, just like the post above, with a twist. BROWSER MOD IF FULLY FUNCTIONAL!!!

....using Nemirtingas emu with "disable_online_networking": false
1. Install mods with mod installer
2. Block game with firewall
3. Run game, get error message and close it
4. Edit user_profile.dat and change "areModsPermitted" to 1 AND "isEnabledMode" to true
...CHANG Nemirtingas emu to "disable_online_networking": true
5. Start the game, wait a few seconds in the menu until the mod browser is unlocked .
6. When this happens, open the mod browser, select mods and play as normal.

I closed the game and reopened it 3 times just to make sure and it still works!!!!

I think we've found a solution guys :D

It works.
The steps I posted above are for the 17.0 version of the game, not the public test, but the official release.

Maybe if you try the version I'm using, EGS RIP by InsaneRamZes.

Here is a link to it:
SnowRunner.Premium.Edition.EGS.Rip-InsaneRamZes v17.0.torrent

Here are the steps The step you need to follow after some tweaking of the method. Follow them carefully to get the mod browser to work, or at least mods to work. You will need some patience, follow this ONLY IF YOU REALLY REALLY WANT TO PLAY WITH MODS as it takes about 15 minutes of "work":
You will need 2 versions of the game. Version 16.0 is for you to activate mods and version 17.0 is the last one you will play.

[Method tested using Epic Games Store version 17.0 Games, using Nemirtingas emu] And using Steam.Rip version 16.0, Codex emu.


... Download the SnowRunner.Premium.Edition.EGS.Rip release from InsaneRamZes [[Please login to see this link.]]. Follow his instructions to get the Nemirtingas emu to work. Use Google Translate to translate the page into English if needed. Inside the SnowRunneren_usSourcesBinnepice_settings folder, open NemirtingasEpicEmu.json with Notepad and make sure "disable_online_networking" is set to false.

"disable_online_networking": false,

... Install the desired mods using the Snowrunner CODEX mod installer, open version 16.0 of the game and activate the desired mods in the mod browser. Click to continue the game, wait for the game to load and open, and then proceed to close the game.

... Block Snowrunner.exe FROM VERSION 17.0 with your system firewall, block incoming and outgoing connections,

... Launch another game (version 17.0) using the shortcut you created (see InsaneRamZes post and instructions, and you'll see why you you need a shortcut), wait in the main menu until Error appears (this may take up to 1 minute), and then close the game.

5.Go to DocumentsMy GamesSnowrunnerbasestorage and REPLACE USER_PROFILE.DAT WITH THE THIS FROM VERSION 16.0 (USER_PROFILE.CFG, CHANG THE EXTENSION FROM CFG TO DAT) located in UsersPublicDocuments SteamCODEX 1465360remote.
edit the user_profile.dat you just replaced with notepad, change the following settings to: "areModsPermitted":1 and "isEnabledMode":true .


Inside the SnowRunneren_usSourcesBinnepice_settings folder, open NemirtingasEpicEmu.json with Notepad and CHANGE "disable_online_networking" to true.
"disable_online_networking": true,

6. Start the game again, wait in the main menu (this may take up to 1 minute) until the mod browser is unlocked. If done correctly, it will unlock
7. When this happens, open the mod browser to make sure mods are enabled. DO NOT CLICK ON ANY OF THE MODS AS THEY WILL BE DISABLED IF YOU DO.

7. Enjoy playing with your mods, FINALLY WORKING!!!!!

You need to wait every time you open the game up to 1 minute until the mod browser is unlocked. Or just click "Download Game" until you see Mod.io is offline, this will unlock the mod browser again and only then you can continue playing.

From now on, if you want to install a new mod, you must first activate it in the mod browser version 16.0 and repeat the process of replacing user_profile.cfg/dat. Then you can play

Always keep a backup copy of your saves, especially user_profile.dat/user_profile.cfg from version 16 (the one where the mod browser works flawlessly without any hooks), as this is the file that will save you and your gameplay.

I hope I can help some of you :)

try this method and experiment with it. Checked closing and opening without defects.

Thank you to everyone who helped make this moment possible!!!!!!

Gorelyi 12.06.22

Edit user_profile.dat and change "areModsPermitted" to 1 AND "isEnabledMode" to true using Nemirtingas emu with "disable_online_networking": false To disable_online_networking" to true.
It did and appeared!!!

Vad44575 12.06.22

I barely found the line "isEnabledMode" in the user_profile.dat file, did everything as in the instructions, but the mods themselves still do not work. Game v.17.0. Do not change anything in the NemirtingasEpicEmu.json file --- if the game starts, then somewhere from the 3rd time. The instructions are completely illogical. I don’t know what and who works there, but elementary logic says that when using the same files, but from different versions of the game or, in general, two games at the same time, but from different versions, there will be a conflict and, as a result , ---- departures. I generally installed version 17.0, completely removing the previous version. In general, when I start the game, I have all mods disabled, and when I try to enable at least 1, error messages appear.

Vad44575 12.06.22

Like these ones:

Gorelyi 12.06.22

SnowRunner - Premium Edition [17.0] (Focus Home Interactive) (RUS/ENG/MULTi13) [L|EGS-Rip] by InsaneRamZes
This build works for me. I took it at the rustic. By the way, as described above, after the warnings, you need to edit the files. user_profile.dat who is not in the know is in the saves, NemirtingasEpicEmu.json in the tabla folder that you throw into the game. Mods do not start immediately, the very first time after all the manipulations they were not active ... I went into the game, then went out to the main menu and appeared. So good luck to everyone!

Benjamin Farraday 12.06.22

catch the guys how to install mods ... bypassed the greed of the developers

despiser 30.06.22



Vad44575, did you find a solution to the problem? I have the same as you. Gorelyi, can you help too?

AndrianPG 30.06.22

What happened to me, maybe something and superfluous.
Launching the mod on Steam version 17.2

This is a post from rutracker (egs version):
1. Before launching the 17th version, rename your old save folder. For example, add -old to the name: It was My GamesSnowRunnerBeta, it became My GamesSnowRunnerBeta-old
2. Run version 17, start the game. It doesn't matter if the game has Internet access or not. Close the game. Make sure a new save folder has been created in the My Games folder: My GamesSnowRunner
3. Move all the contents of the old save folder to the newly created folder.
4. Find the file My GamesSnowrunnerbasestorageUSER_PROFILE.DAT there and edit it with notepad. You need to change all parameters to the following: "areModsPermitted":1 And "isEnabledMode":

The ESG version crashes on boot. On Steam notification like Vad44575.
Since CODEX saves elsewhere: :UsersPublicDocumentsSteamCODEX1465360
!!COPIED!! save data to the folder :UsersUserDocumentsMy GamesSnowRunnerbasestorage (and also, just in case, to basestorage76561197960267366) Launched
without connecting to the Internet. Map mod launched

Orionchik 30.06.22

I did everything as in the post above, the game starts up, but the mods are not included, all the flags are set to TRUE
What else could it be? I ran the game offline without internet.

VladKonPerm 09.07.22

SnowRunner - Premium Edition [17.0] (Focus Home Interactive) (RUS/ENG/MULTi13) [L|EGS-Rip] by InsaneRamZes basestorageUSER_PROFILE.DAT and edit it with notepad, change all parameters to the following: "areModsPermitted":1 AND "isEnabledMode":true" Mods have appeared.

GriK142 03.09.22

Who does not include mods in version 17. Here is the solution.
Version 17 (17.3 for example) should work for you - the mod manager opens, but you cannot enable disabled or new mods. Everything is simple. Open the user_profile.dat file with notepad and look for modStateList in it. There will be parameters in square brackets - in my case, for example:
"modStateList": [{"modId":143554,"modState":true}, {"modId":2251515,"modState":true}]
Then everything is clear, I think . These are all INCLUDED mods. Add your own according to the template - and they will be included in the mod manager. You can play.
Good luck to all. The game version is EGS.Rip-InsaneRamZes.17.3.

McON 03.09.22

And if the mod manager does not come off?

GriK142 03.09.22

I followed these instructions:
1. Block the game with a firewall (in, internet out)
2. Start the game, get an error message (for mods) and close it
3. Edit user_profile.dat and change "areModsPermitted" to 1 . "isEnabledMode" to true
and in the NemirtingasEpicEmu.json file (from the crack) "disable_online_networking": true
4. Start the game, wait a few seconds in the menu until the mod browser is unlocked.
5. When this happens, open the mod browser, select mods and play as usual.
After that, all the old enabled mods will work. Well, include new ones - in the post above.
Installing mods according to this instruction:

McON 03.09.22

Thank you very much!
Everything worked.

S_Xim 03.09.22

Hello, tell me what I'm doing wrong. Game version - EGS.Rip-InsaneRamZes.17.3 (+ worth Real Life Mod & Bug Fix for Phase 7 for SnowRunner by SV.PAM and Realistic Tranmissions by eclipse538), installed mods and activated according to instructions from GriK142, added two mod, they are connected and working, but when you try to add more modifications, the game gives a warning, in the mod manager there is an inscription about the absence of the Internet and rewrites user_profile.dat , you can connect already working mods by rewriting the user profile, there are no new ones, what should I do?